
A Guide to EXeLearning 2.1 

Preface 
This guide to exelearning 2.1 is largely based on a translation from the Spanish language web 

resource at http://exelearning.net/html_manual/exe20/index.html and was  created by Visimpscot.  

We are based in the east of Scotland but have also worked in Asia, East Africa and  the Pacific. 

Concentrating on delivering quality IT training, we specalise in helping the 'not for profit sector' and 

users with sensory, physical or cognitive impairments. You can contact us by emailing 

visimpscot@live.co.uk  or visit our website at http://tinyurl.com/visimpscot . 

The guide does not cover every possible operation or optional setting of eXeLearning, although it 

provides a good grounding for you to build on. 

The screen shots were taken from eXelearning 2.1 portable version running on  MS Windows 10 with 

a Mozilla Firefox web browser.  This guide is published under a creative commons: attribution - 

share alike 4.0 license. 

What is eXeLearning? 

eXeLearning is an open source tool for the creation of educational content. This guide does 
not cover every possible operation and variations between program versions 

Install eXeLearning on your favourite operating system (Windows, MAC or Linux) and use 
your preferred browser to work with it.  

eXeLearning aims to makes it easy to use your content locally or on the Internet, it can be 
exported to HTML, HTML5, SCORM1.2, SCORM2004, IMS, ePub3 or other formats and 
published as a stand alone piece, or in a learning management system (LMS) such as Moodle 
or another similar platform.  

eXeLearning.net is an open project. Visit eXeLearning.net, raise suggestions, improvements 
and new utilities. Your collaboration is welcome. 

  

mailto:visimpscot@live.co.uk
http://tinyurl.com/visimpscot
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Introduction  

goals  

 Know the installation of eXeLearning in the different operating systems.  
 Know the main characteristics of the eXeLearning work environment.  
 Be able to create a project with the tool using its basic functions.  
 Know the different styles offered by eXeLearning.  
 Master  advanced functions offered by the editor.  
 Export content in different formats.  
 Publish on the web.  

Windows Installation  

What steps should you follow to install eXeLearning?  

Step 1:  

Download from http://exelearning.net/en/descargas/ the right version to your operating 
system, in this case MS Windows (eXeLearning is cross platform with Linux and Mac versions 
as well).  

Follow the following steps:  

1. Download eXeLearning.  

2. Save the file.  

3. Install the package.  

4. Launch the application.  

5. Set the language.  

There is a version of eXeLearning that does not need to be installed in Windows. Its name is 
Portable you can run it from a memory stick or download it to your PC.  

eXeLearning Portable: with you anywhere  

The Portable version of eXeLearning lets you take the application wherever you go.  

Your styles, language, list of idevices, ... you can keep your eXe customized on any computer 
without installing it.  

  

http://exelearning.net/en/descargas/


The Portable version, can be run without special permissions, from a memory stick and 
working with an eXe made to your needs (modified styles, the preferred language or the list 
of iDevices that you want). In this way you can keep your eXe personalised, and you can use 
that personalised version anywhere.  

Double-clicking on the exelearning.exe file will launch your application.  

 eXe Portable is a compilation made by Francisco Macías 

Work environment  

When opening eXeLearning you will find fyour youll differentiated areas:  

 1 Structure :  create indexes of your contents.  
 2 Main menu :  manage files, printing, exports, styles, user preferences and help.  
 3 iDevices : different activities to include in the generated content.  
 4 Work area : in the "Authoring" tab you can see the created contents and in 

"Properties" you can include metadata referring to your creations.  

In the following screenshot you can see the distribution of these fyour work zones in which 
eXe is divided:  

 
Move the mouse pointer over the image to expand the information. 



Structure  

 

With the tools in the "Structure" block, you can create a content tree . If you have a lot of 
content you can structure it in Themes, Sections and Units so that content is more 
understandable and accessible.  

At the start of any eXeLearning project is a node or page called "Start", node from which all 
your content will hang. This is called the "parent node".  

Add page / Delete / Rename  

To add new nodes or pages, select the node from which you want the new pages (children) 
to hang (parent) and add a page. A new node will be created that you can rename to your 
liking or delete it.  

 To rename a node or page, select it and click on the "Rename" link. Double clicking 
on the selected node has the same effect.  

 To delete a node, select it and click on the "Delete" link. Remember that the page 
and all the content on it will be deleted.  

Move a node up / down in the hierarchy 

The arrows "raise and loyour a node in the hierarchy" and "move a node up or down" will be 
found in the loyour part of the "Structure" block and with them you can increase or 
decrease the importance of a page and change them in order.  

Delete a node 

Be careful using the Delete a node option. If you use it to delete a node that has sub-nodes 
or child nodes, eXelearning will delete them all.  



Practice eXe: modify the structure  

Try the following procedures:  

1. Create a folder on your PC called "eXe Learning Course".  

2. Download the U1_A1.elp file to the "eXe Learning Course" folder.  

3. Open the file U1_A1.elp (You can double click on it).  

4. Order the structure.  

5. Rename "Theme 1" for "My first theme."  

6. Delete the node or page named "Section 1.3".  

7. Create a new node called "Section 2.3" and sort it appropriately.  

8. Save the changes ( File> Save ).  

9. Main menu  

10. In the eXe main menu you will find a series of options; necessary to perform tasks  

In the "File" menu you will have the basic options to open, save and export files and options 
such as print, import and merge ELPs (Exelearn packages) such as open, save, print, export, 
create - show - hide iDevices, select styles ... 

  

Practice eXe: save as ...  

Perform the following procedures:  

1. Open the U1_A1.elp file in your "eXe Learning Course" folder.  
2. Change the name to myfile . Save it in the "eXeLearning Course" folder ( File> Save 

as ... )  

Practice eXe: your first export  

Try the following procedures:  

1. Open the file myfile.elp in your "eXeLearning Course" folder.  
2. Export the file to Website, Self-contained folder ( File> Export> Website> Self-

contained folder )  
3. Make sure the folder is generated on your desktop. Browse the eXe file browser. 



Quit  

You will use this option when you want to leave the application. Its use is recommended 
because if you do not have saved the latest changes to your content you will ask us if you 
want to save the changes.   

Tools  

IDevices editor  

In "iDevices Editor" are the tools to create, export and import new iDevices. These are 
advanced eXe user options.  

Style manager  

In the style manager you can import a style not present in the eXelearn, export installed 
styles and delete unwanted styles.  

If you delete a style and have not saved a copy, do not worry. You can reinstall it by 
downloading it from http://exelearning.net/category/descargas/descargar-plantillas/ 

  

http://exelearning.net/category/descargas/descargar-plantillas/


Preferences  

In "Preferences" there are two tabs:  

1. General configuration : you can select the language and the browser you want to use to 
work with eXe.  

 

3. Advanced :  

 Default format for new documents: HTML5 or XHTML. It allows to choose which 
format new files are created by default.  

 Editor mode: Permissive or Strict. In permissive mode, the editor will accept any type 
of code and will not delete or modify what does not meet the HTML5 or XHTML 
standards.  

 The use of internal links will only be valid for exports to the website.  



 

Report on resources  

This will create a CSV file where all the elements and files contained in the elp that is being 
generated will be registered. This is an option for large projects and is useful for advanced 
developers.  

Preview  

With this option you can see a preview in HTML format of the contents created in 
eXeLearning.  

This is a preview, to share your work save it and then export it to the format you want.  

Refresh screen 

This option you will update the screen of your work.   

  



Styles and Help  

Styles  

In the section "Styles" of the eXeLearning main menu you can modify the visual aspect that 
your contents will have. To do this display the "Styles" menu and mark the box of the style 
you want to use.  

Bear in mind that, depending on the export options chosen, the results may vary from the 
preview in eXe. With Utilities> Preview you will see its appearance as HTML  

In the latest  version of eXeLearning, exports of content are responsive ,  adapting to the 
type and size of the device on which the content is viewed.  

There are new and improved styles.  

Help  

In the "Help" menu you will find links to tutorials and eXe manuals, notes of the version you 
have installed and links to the website and eXeLearning.net forums where you can ask 
questions, report errors and request new features.  

Style designer  

Creating a style in eXeLearning, personalized, with different colours, background images and 
header, is easy.  

Using the option Tools> Style Designer> Create a new style.  

Once done, name it and you will find the new style in the eXeLearning styles menu.  

Remember, you can always edit your new style again or make new one based on it.  

All the styles incorporated in eXeLearning are responsive  

Responsive or adaptive web design, known by the acronym RWD, is a design and 
development philosophy whose objective is to adapt the appearance of web pages to the 
device used to view it. Today web pages are displayed on many types of devices such as 
tablets, smart phones, e-book readers, laptops, PCs ... Even within each type, each device 
has its specific characteristics: screen size, resolution, CPU poyour, memory capacity, ... This 
technology claims that with a single web design, you have an adequate display on any 
device.  

from Wikipedia 

Your content will be adapted to the device on which it is played!  

https://translate.googleusercontent.com/translate_c?depth=1&hl=en&prev=search&rurl=translate.google.co.uk&sl=es&sp=nmt4&u=http://exelearning.net/forums&xid=17259,15700002,15700022,15700124,15700149,15700168,15700173,15700186,15700201&usg=ALkJrhhIx9yrmYbz89Y3ycg753s-DCwrug


Style manager  

In the eXeLearning 2.1. + Version, a new styles download service has been introduced from 
the remote repository hosted on the eXeLearning.net website (templates section  ).  

This repository expands the collection of styles available in eXeLearning. On the one hand, it 
makes available all the "official" styles, updated day by day, and on the other open the 
possibility of sharing other styles not available in the application, they can have significant 
variations in effects, design and functionality.  

The Styles repository  

What steps should you take to use the Styles Repository styles download service?  

Step 1: Access the Style Manager in the Tools menu 
 
Step 2: Access the Styles repository  
 

 



iDevices and Work Area  

 

The iDevices are elements that allow you to include different types of content. You will 
organize them by categories, according to the type of action or presentation they carry out.  

• iDevices of presentation of information in textual form   

• iDevices of non-interactive activities  : propose activities that can not be answered directly.  

• iDevices of interactive activities  : allow the learner to interact directly with the object.  

• iDevices for presentation of non-textual information  : images, files and web pages.  

Ungroup / Group iDevices  

This button toggles show the iDevices by categories or ordered alphabetically.  

Edit the iDevices  

With this option you can choose the idevices that you want to show. You will just have to 
select them and save the changes.  

Practice eXe: hide and show iDevices  

Try the following procedures:  

1. Open myfile.elp in your "eXe Learning Course" folder.  
2. In Edit the iDevices , show the iDevice "FPD - Multiple Choice Activity".  
3. Click on the "Save iDevices" button. (Note that it appears in the list of iDevices)  
4. Repeat the process this time hiding the iDevice that you have shown previously.  

Work area: "Authoring"  

This is the tab that you use to include the iDevices and your contents. The "Authoring" tab is 
your area of work and creation.  



Work area: "Properties"  

When clicking on the "Properties" tab you will find three tabs:  

" Package ": you can carry out the cataloging and complete the data of your project:  

 Title : set the title of the project. It will appear at the top of the object created in 
most styles.  

 Language : select the language of your content. The language selected in Tools> 
Preferences appears by default .  

 Description - General: summary of the contents of the resource.  
 Description - Objectives : list of the objectives that are intended with the resource.  
 Description - Prior knowledge : necessary or advisable requirements to start working 

on the resource.  
 Author : allows you to include the name of the author of the project.  
 License : gives the option to select the type of license of the content.  
 Type of educational resource : select the type of resource that best suits yours in the 

drop-down list.  
 Usage specifications : select the options that best suit your resource.  
 Header background : allows you to insert an image that will be displayed in the 

upper left of the project pages. It will be repeated and will be below the title. This 
option is not enabled in all styles.  

 Footer : gives the possibility of including a footer.  
 Description : allows you to enter a brief description of the project.  
 Taxonomy : gives the option to modify the default names of the nodes at their 

creation.  
 Advanced options : you can check the compatibility box with previous versions of 

eXe. This option will remove the metadata entered in this tab in the package.  

" Metadata ": data that describes other data. In general, a group of metadata refers to a 
group of data, called a resource . The concept of metadata is analogous to the use of indexes 
to locate objects instead of data. For example, in a library they use tokens that specify 
authors, titles, publishing houses and places to look for books. Thus, metadata helps locate 
data. (Obtained from Wikipedia)  

 

 Dublin Core is a metadata model developed and sponsored by the DCMI (Dublin 
Core Metadata Initiative).  

 LOM (Learning Object Metadata) is a data model used to tag and describe a learning 
object and other similar digital resources. Thanks to its use in the cataloging of the 
object, it is easier to find it later in the resource banks.  

 LOM is an international standard and its adaptation to the Spanish educational 
context is LOM-ES ( http://educalab.es/intef/tecnologia/recursos-digitales/lom-es)  

https://translate.googleusercontent.com/translate_c?depth=1&hl=en&prev=search&rurl=translate.google.co.uk&sl=es&sp=nmt4&u=http://es.wikipedia.org/wiki/Metadato&xid=17259,15700002,15700022,15700124,15700149,15700168,15700173,15700186,15700201&usg=ALkJrhi_78-8KQsM9EYdQn4SqsA2fke2PA#cite_note-3
https://translate.googleusercontent.com/translate_c?depth=1&hl=en&prev=search&rurl=translate.google.co.uk&sl=es&sp=nmt4&u=http://es.wikipedia.org/wiki/Metadato&xid=17259,15700002,15700022,15700124,15700149,15700168,15700173,15700186,15700201&usg=ALkJrhi_78-8KQsM9EYdQn4SqsA2fke2PA#cite_note-3


The use of metadata is very important so that your resources are easily searchable by search 
engines and specialized repositories of educational objects.  

If you have filled in the options of the package tab, you will fulfil the minimum cataloging 
requirements LOM-ES.  

" Export ": in the new version of eXe, all the exported content generated with the tool will 
be editable by default. That is, you can open eXe packages scorm, ims, html, ... that have 
been generated with this version in addition to the eXe packages themselves (.elp). The 
default cataloging option will be LOM-ES.  

 

Practice eXe: you are a content creator  

Try the following procedures:  

1. Open myfile.elp from your "eXeLearning Course" folder.  
2. Complete the elements of the "Package" tab. Remember to save the changes to the 

form on the Save button .  
3. Save the modified file.  

  



The text editor  

Version 2 has updated the version of the TinyMCE editor to version 3.5.11.  

This update, resolves errors in the previous version and includes a series of improvements 
that make the user experience more satisfying, incorporating new functions and effects, in 
addition to improving the generated code.  

TinyMCE  is the WYSIWYG (What You See is What You Get) text editor for HTML that is used 
in eXeLearning.  

 

Next you will see the editing capabilities it presents:  

First row  

In the first row you will find the necessary tools for the editing text.  

 

Second row  

In this row you will find the necessary tools for formatting text and adding links. 

 

Third row  

In this row you will find the fundamental elements for images,multimedia elements such as 
videos, prezy type resources, slideshare ... and everything that can be shared on the web, 
plus working with html code. 

 



 

Paste options  

In eXeLearning you can paste any textual content of a web page or document whose license 
allows it, use the Ctrl + V keys to paste this content.  

To achieve the best result, take into account the buttons available and the differences 
between different ways of pasting.  

It allows us to paste ( Ctrl + V ) from the clipboard the text previously copied or cut. 
You must bear in mind that in this type of paste, you will copy the "trash" code of the 
original document, which may give us problems later when modifying the format or text 

pasted. To clean this code, you will select the text and use the clean format buttons 

or clean up garbage code .  

IMPORTANT:  copied images will not be pasted using the paste option (Ctrl + V)  

Paste as plain text . This type of paste is useful when you copy (or cut) from a web 
page and you want to paste the text but NOT the formats and styles of origin .  

Paste  from external applications, LibreOffice , OpenOffice etc. 

You will need to do a little practicing to observe the differences.  

Paste as plain text.  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Create an iDevice "Free text" in the "Format text" node.  
3. Copy (Ctrl + C) the three text paragraphs of this web: Dysarthria  

4. Click on the "Paste with / without format" icon in the iDevice text field. Once 

finished, you will click on the button to see the result.  
5. Save the changes. ( File> Save )  

Paste.  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Create an iDevice "Free text" in the "Format text" node.  
3. Copy (Ctrl + C) the three text paragraphs of this web: Dysarthria  
4. Paste in the iDevice text field using the Ctrl + V keys. Once finished you will click on 

the button to see the result.  
5. Save the changes. ( File> Save ) 

https://translate.googleusercontent.com/translate_c?depth=1&hl=en&prev=search&rurl=translate.google.co.uk&sl=es&sp=nmt4&u=http://cedec.ite.educacion.es/es/noticias-de-portada/1450-disartrias-cuando-la-comunicacion-oral-esta-alterada&xid=17259,15700002,15700022,15700124,15700149,15700168,15700173,15700186,15700201&usg=ALkJrhiK0xGNWm5nfd6LWSc3WN-1BIHNQw
https://translate.googleusercontent.com/translate_c?depth=1&hl=en&prev=search&rurl=translate.google.co.uk&sl=es&sp=nmt4&u=http://cedec.ite.educacion.es/es/noticias-de-portada/1450-disartrias-cuando-la-comunicacion-oral-esta-alterada&xid=17259,15700002,15700022,15700124,15700149,15700168,15700173,15700186,15700201&usg=ALkJrhiK0xGNWm5nfd6LWSc3WN-1BIHNQw


FX effects: accordion  

This button  It allows us to create various effects in your content.  

The "Accordion" effect arranges content within a list that can be displayed or collapsed by 
clicking on each title. 

Creating an accordion type effect will be very simple. For this you will follow the following 
steps:  

1. Click on the button of the editor  

2. In the window that appears, select the "accordion" option.  

 
 
3. A box will be created with two headers (which you can edit to put the title you 
want) and two spaces to write content to show or collapse. You can edit it and 
incorporate any type of multimedia resource.  

 



4. To create a new item from the list, you will write the title that you want to 
incorporate and the desired content within the created FX box. You will mark the 
title and select the "Heading 2" format option  

FX effects: tabs  

How to do it?  

Creating an accordion type effect is very simple. For this you will follow the following steps:  

1. You will click on the button of the editor  

2. In the window that appears, 

 select the option "tabs".  



 

3. A box will be created with two headers (which you can edit to put the title you want) 
and two spaces to write content to show or collapse. You can edit it and incorporate any  

4. To create a new item from the list, you will write the title that you want to 
incorporate and the desired content within the created FX box. You will mark the title 
and select the "Heading 2" format option  

FX effects: paging  

The button It allows you to create various effects in your content.  

The "Pagination" effect allows you to quickly change what you are seeing without having to 
change pages.  



 

 

FX effects: carousel  

The button It allows us to create various effects in your content.  

The effect "Carousel" is to offer additional information taking advantage of the space.  

 

 



FX effects: timeline  

The button It allows us to create various effects in your content.  

The "Timeline" effect allows you to quickly change what you are seeing without having to 
change pages.  

 

List of definitions  

The button "List of definitions" lets you create a list of terms or concepts in which the 
definition or explanation of them is hidden. You can display each definition or explanation 
by clicking on the definition or using the + icon to display them all at once.   

Quotations with authorship  

The option to include "Quotations with authorship"  aids using this type of resource and 
includes the possibility of styling it.   

How to do it?  

Clicking the button you can paste the text of the quote and mention the author of it. In 
the event that the appointment and the author have a different language to the resource 
that you are preparing, you can specify them.  



 

Also included is the option to use your own appointment style. You can always edit the 
appointment once created.  

Hyperlink (inclusion of file information)  

In the case of linking a file, the "Insert / edit hyperlink" lets you automatically including 
information on the file, its size the file extension.  



 

HTML code editor  

The HTML button in the editor  shows a window in which there are some new features. 
You can see the highlighted  HTML code, with auto-completion, improved display of the 
HTML code and the addition of a "search and replace" option.  

Addition of paragraph at the end  

Add a paragraph at the end is a function limited to cases when the editor cursor  does 
not manage to leave a layer <div> </ div>.  

The effect achieved is to add in the editing window a paragraph that contains three points:  



 

Lightbox effects  

Lightbox is a JavaScript library that displays images and videos by filling the screen, and dimming out 

the rest of the web page.  

There is an improved Lightbox effects library. With this update you can make a lightbox 
effect on an image that can show images and videos.  

How to do it?  

Image to image:  

1. Insert the image  
2. Click on the inserted image and insert a link.  
3. In the hyperlink direction, you examine and attach the image again.  
4. In the tab Advanced> Relation page to destination you select the option Lightbox.  



 

Image to video:  

1. Insert the image  
2. Click on the inserted image and insert a link.  
3. In the hyperlink address, you paste the URL of the YOUTUBE video.  
4. In the tab Advanced> Relation page to destination select the option Lightbox.  



 

Gallery of images and videos:  

1. Insert images  
2. Click on each inserted image and insert a link.  
3. In hyperlink address, you examine and attach the image again or paste the URL of 

the YOUTUBE video.  
4. In the tab Advanced> Relation page to destination you select the option Lightbox for 

each one of the images.  
5. You open the sourcecode editor and put the same number in square brackets to 

each tag rel = "lightbox"  

So if the HTML code is:  

<a href="actividad_generica_engranaje.png" rel="lightbox" title="Engranaje"> <img 
src="actividad_generica_engranaje.png" width="200" height="200" /></a> <a 
href="actividad_generica_estrella.png" rel="lightbox" title="Estrella"> <img 
src="actividad_generica_estrella.png" width="200" height="200" /></a> <a 
href="https://www.youtube.com/watch?v=cI61i-
fgkek&amp;list=PLgnSGd4uwSUn8o_f31_ZCsB_mM2Q1tDII&amp; index=1" title="Vídeo de eXeLearning" 
rel="lightbox" > <img src="actividad_generica_exe.png" width="200" height="200" /></a> 
  



The result would be:  

 <a href="actividad_generica_engranaje.png" rel="lightbox[1]" title="Engranaje"> <img 
src="actividad_generica_engranaje.png" width="200" height="200" /></a> <a 
href="actividad_generica_estrella.png" rel="lightbox[1]" title="Estrella"> <img 
src="actividad_generica_estrella.png" width="200" height="200" /></a> <a 
href="https://www.youtube.com/watch?v=cI61i-
fgkek&amp;list=PLgnSGd4uwSUn8o_f31_ZCsB_mM2Q1tDII&amp; index=1" title="Vídeo de eXeLearning" 
rel="lightbox[1]"> <img src="actividad_generica_exe.png" width="200" height="200" /></a> 
  

Tool tip 

‘A tooltip (also called emergent description) is a visual aid tool, which works by placing the 
cursor over a graphic element, showing an additional help to inform the user of the purpose 
of the element on which it is located.  

The tooltip is a variation of the help balloons and is a very used complement in 
programming and design, given that they provide additional information without the need 
for the user to request it actively.  

from Wikipedia  

You should not misuse the "Tool Tip" effects. You do not have to make them very extensive 
or add very wide images. ToolTips only support a width below 300 px.   

How to do it?  

After the text is created, select the word for which to add a tool tip to.  

Choose from the three available types (Link , Text or Page) and configure the behaviour and 
appearance. 



  

Insert HTML as text  

The button It lets you display HTML (and other programming languages) as text.  

 



The "Html as text" button lets you displays HTML  or other code in the document, 
highlighting the syntax with colours (accepts different programming languages), highlighting 
lines and selecting the appearance  

Lists with automatic numbering  

You can easily create numbered lists without having to manually type the numbering:  

Normal numbered list:  

1. First chapter  
1. First section  

1. Another section  
2. Chapter two  

List with automatic numbering:  

1. First chapter  
1. First section  

1. Another section  
2. Chapter two  

As you can see, it automatically inserts the numbering (1.1.1 ...) You find this type of list by 

displaying the options of the ordered list :  

  



Hangman  

Do you remember how the word game hangman is played? Click on the Insert menu to add 
a hangman game.  

 

  



The iDevices  

 

 iDevices are instruments that let you use different pedagogic resources. These range from 
true-false questions to more complex ones such as java applets. The great advantage of 
eXeLearning is that you can create new iDevices if you need to.  

The eXeLearning 2.1 version has 20 main iDevices, each with a different pedagogical or 
technical use.  

iDevices to present information in textual form.  

iDevices of non-interactive activities : propose activities that can not be answered directly.  

iDevices for the presentation of non-textual information (images and web pages).  

iDevices of interactive activities : allow the learner to interact directly with the object.  

iDevices for textual information  

To present content or themes (including images, videos, multimedia content ...) you  have the 

following iDevices:  

 Free text : similar to how you work with a normal text editor.  

 Objectives: to show the objectives in a highlighted text box and with an icon to 
emphasize the content.  

 Prior knowledge : this is intended to include the contents that the learner must 
know to under take an activity. It also appears as highlighted text and with an icon.  

 Note : this is intended to include comments and annotations of the content 
designer. This iDevice will NOT be visible in any of the exported formats.  

 



Free text  

This is the most widely used iDevice because it will allows adding content through a text 
editor. You use it mainly to make show a topic and present the contents.  

Selecting the iDevice "Free Text" from the list of iDevices this will be shown in your 
eXeLearning:  

 

In the central text field, you write your content.  

When finished click on the button to see the result.  

Using the options you can undo the changes, 
delete the iDevice, move it up, move it down or move it to other nodes created earlier.  

The icons for help and information  offer additional information about the iDevice that 
you are using.  

  



Free text example:  

 

This is a sample of text created with the free text iDevice.  

You can include images, links and any type of audiovisual content.  

Practice eXe:  format texts  

Try this:  

1. Download the U2_A1.elp file to a new folder called "eXe Learning Course"  
2. Open the file U2_A1.elp with eXelearning 

3. Click on the "Edit" button of the iDevice "Free text" found in the "Format 
text" node  

4. Modify the font size of the first paragraph.  
5. Change the text color of the second paragraph.  
6. Select a word and modify the background color.  
7. Save the changes. ( File> Save )  
8. Justify the text of the third paragraph.  
9. Insert a subscript and a superscript into a word of your choice.  
10. Select the three paragraphs and create an ordered list.  

11. Once finished, click on the button to see the result.  
12. Create a new iDevice "Free text" and write some text  
13. Change the name to myfile2 . Save it in the "eXeLearning Course" folder ( 

File> Save as ... )  

  

http://exelearning.net/html_manual/exe20/U2_A1.elp


Objectives  

Use this iDevice to show the objectives that will or have been met by the content.  

Selecting "Objectives" from the list of iDevices this will be shown in eXeLearning:  

 

At the top, you can modify the title of the iDevice .  

In the central text field , you write your content. With the text editor, you can insert images, 
multimedia content ...  

Remember:  

 Once finished, you will click on the button to see the result.  

 Using the options you can undo the 
changes, delete the iDevice, move it up or down the content tree and move it to 
other nodes previously created in your work in eXeLearning.  

 The icons of Instructions and help they will offer additional information about 
the iDevice that you are using.  

Example of Objectives: In this module you will learn ...  

 Use the different iDevices  
 Choose the most appropriate for each type of activity  

  



Practice eXe:  create an iDevice "Objectives"  

Perform the following procedures:  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Select the "Format text" node.  
3. Create an iDevice "Objectives". Move it up. Modify your title  
4. Create a sorted list with the names of the nodes that exist in the file myfile2.elp .  

5. Once finished, click on the button to see the result.  
6. Save the changes. ( File> Save )  

If you have any questions you can check the following video:  

Prior knowledge  

Use this iDevice to indicate the contents that a learner needs know to carry out an activity.  

When selecting "Previous knowledge" from the list of iDevices this will be shown in your 
eXeLearning:  

 

At the top, you can modify the title of the iDevice .  

In the central text field, you can write content. In the text editor, you can insert images, 
multimedia content ...  

  



Remember:  

 When finished click on the button to see the result.  

 Using the options you can undo 
changes, delete the iDevice, move it up or down the content tree or move it to other 
nodes previously created in your work in eXeLearning respectively.  

 The icons of Instruction  and help  offer more information about the iDevice  
you are using.  

Example of prior knowledge: you have to master ...  

To successfully complete the Course, you have to master:  

 Basic HTML  
 Digital edition of images  

You can find more information on Wikipedia 

Practice eXe: Previous knowledge  

Perform the following procedures:  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Create an iDevice "Previous knowledge" in the "Format text" node. Modify the title.  
3. Move it up so that it is below the iDevice "Objectives".  
4. Write a text in which you describe the objectives you intend to achieve in the Course 

you are doing.  
5. Include an external link that opens in a new window.  

6. Once finished, click on the button to see the result.  
7. Save the changes. ( File> Save )  

Note  

This  iDevice is intended to make comments about your work. In the case of elaborating a 
content among several authors, it will be useful to write annotations, modifications and 
comments to facilitate collaboration. This iDevice will NOT be shown in any of the exports.  

By selecting the iDevice "Note" from the list of iDevices the following will be shown in your 
eXeLearning:  



 

In the central text field, you will introduce your comments.  

Once finished you will click on the button to see the result.  

 

Important : The red erase icon will remove ALL notes from the .elp file you are working on.  

To make persistent notes or comments that will be kept in exports of your elp package place 
comments in the HTML code (An HTML comment begins with <!–– and the comment closes with –
–> . HTML comments are visible to anyone that views the page source code, but are not rendered 
when the HTML document is rendered by a browser.) 

iDevices of non-interactive activities  

To add activities with a feedback button, use the following iDevices:  

 Activity : to pose an activity to the learner in a highlighted text box and with an 
icon that emphasizes the content shown.  

 Reflection: An activity a question or text on which the learner should reflect. In 
the feedback, complementary information can be included to carry out the 
activity.  

 Reading activity : A reading accompanied by an activity. In the feedback, extra 
information can be included to assist in carrying out the activity.  

 Case study: proposes the study of a case (real or imaginary). In the feedback 
extra information can be included to assist in carrying out the activity.   



 

Activity  

Use this iDevice preferably to indicate an activity, exercise or task.  

When selecting "Activity" from the list of iDevices this will be shown in your eXeLearning:  

 

At the top, you can modify the title of the iDevice .  

In the central text field, write your content. In the text editor, you can insert images, 
multimedia content ...  

Remember:  

 If you want, you can use the iDevice "Activity" for other types of activities. Use your 
imagination ! Experiment and think how it can be useful in other proposals that you 
have in mind.  

  



Activity Example: Looking for Goya  

 

Header of the image  

 
You will have to find the author ... The work ( Public domain )  

The image you see above is entitled "The work" and belongs to a well-known Spanish author 
of the eighteenth century born in Fuentedetodos, province of Zaragoza in 1746.  

His work includes easel and mural painting, engraving and drawing. In all these facets 
developed a style that inaugurates Romanticism. Also, his work is the beginning of 
contemporary painting, and is considered a precursor of the pictorial vanguard of the 
twentieth century.  

You will have to find out which author you are talking about and make a text document in 
which you present your life and attach some of your most representative pictorial works.  

Practice eXe: Insert images  

Perform the following procedures:  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Select the "Insert images" node.  
3. Create an iDevice "Activity".  
4. Write the text of an activity in which you ask your learners to do a search for images 

of a painter of your liking.  
5. Find a work by that painter and save it in the folder "Course of eXeLearning".  
6. Insert the downloaded image on the first line using the "Insert / edit image" button. 

Complete the "Image description" and "Title" fields. Modify the width of the image 
in the "Appearance" tab. In the "Header and caption" tab, complete the fields and 
determine the license. Press the "Update" button.  

7. When finished, click on the button to see the result.  
8. Save the changes. ( File> Save )  



Reflection  

Use this iDevice to propose an activity a question or text on which the learner should reflect.  

Selecting "Reflection" from the list of iDevices will show this in eXeLearning:  

 

At the top, you can modify the title of the iDevice.  

In the field " Reflective question " you  write the proposed text on which your learners 
should reflect.  

In the " Feedback " field, you provide learners with information on the important points to 
take into account in the reflection process.  

Remember:  

In iDevices with several text boxes, you can write directly to them. If you want the editor to 
be shown, click on the "Editor" link.  

In this way creating activities is simpler, faster and more intuitive.  

  



Practice eXe: You Tube videos   

Perform the following procedures:  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Select the "Insert videos" node.  
3. Create an iDevice "Reflection" and modify its title.  
4. Search for a You Tube video you like. Copy the URL of the video.  
5. In eXe, click on the "Insert / edit embedded media" button and paste the URL of the 

Youtube video. Press the "Insert" button.  
6. Write a text where you enter an explanation of the video you have embedded and a 

reflective question about it.  
7. In the field of feedback write some questions about which your students should 

reflect or take into account in the proposed reflection.  

8. Once finished, click on the button to see the result.  
9. Save the changes. ( File> Save )  

  



Reading activity  

Use this iDevice to propose to the students a reading accompanied by an activity that they 
must complete. It gives the possibility of using a feedback that the student will be able to 
visualize when he considers it appropriate.  

When selecting "Reading activity" from the list of iDevices this will be shown in your 
eXeLearning:  

 

At the top, you can modify the title of the iDevice.  

In the field " What to read " write the proposed text to your students.  

In the field " Activity " indicate the instructions to perform the proposed reading activity.  

Lastly, in the " Feedback " field, include those information and indications that may help or 
complement your student to carry out the proposed activity.  

  



Remember:  

In iDevices with several text boxes, you can write directly in them. If you want the editor to 
be shown, you have to click on the "Editor" link.  

In this way the creation of activities is simpler, faster and more intuitive.  

Reading Activity Example: Listening to "Don Quixote"  

In a place in La Mancha, whose name I do not want to remember, there has not been a long 
time that lived a hidalgo of the spear in shipyard, old buckler, skinny horse and galgo 
corridor. A pot of something more cow than sheep, salpicón more nights, duels and losses on 
Saturdays, lentils on Fridays, some palomino addition on Sundays, consumed the three parts 
of his farm. The rest of the sailor's coat concluded, hairy breeches for the holidays with their 
slippers of the same, the weekdays you’re honored with their vellori of the finest. He had in 
his house a mistress who was over forty, and a niece who was not yet twenty, and a young 
man from the countryside and the plaza, who saddled the horse as he took the pruning 
shear. The age of your gentleman was about fifty years old, he was of strong build, dry of 
flesh, thin of face; great early bird and friend of the hunting. They want to say that it had the 
nickname of Quijada or Quesada (that in this there is some difference in the authors who 
write in this case), although by credible conjectures it is understood that it is called Quijana; 
but this matters little to your story; it is enough that in the narration of him a point of the 
truth does not leave.  

Read the text carefully while listening to the audio of chapter one of "Don Quixote". Next, 
answer the questions you asked you.  

Practice eXe: inserting video and audio  

Perform the following procedures:  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Select the "Insert videos" node.  
3. Create an iDevice "Reading activity" and modify its title.  
4. Find an audio of your liking. Download it to your local.  
5. Write a reading text inside the iDevice. Give it the format you want.  
6. Insert the audio you have previously downloaded in the "Insert / edit embedded 

media" option  
7. Below the audio, it includes information about the activity.  
8. In the option "Feedback" write the questions or activities. Incorporate, if you wish, 

some additional information.  

9. Once finished, click on the button to see the result.  
10. Save the changes. ( File> Save )  



Case study  

Use this iDevice to propose the study of a case (real or imaginary).  

When selecting "Case study" from the list of iDevices this will be shown in your eXeLearning:  

 

At the top, you can modify the title of the iDevice.  

In the field " History " you will write the text from which your students will do the activities.  

In the field " Activity " you indicate the instructions to perform the proposed reading 
activity.  

Finally, in the field " Feedback ", you include those information and indications that can help 
or complement your student to perform the proposed activity.  

Unlike the iDevice "Reading activity", in "Practical case" you can create new activities with 
feedback related to the initial story. You will have to click on the Add another activity 
button.  

  



Remember:  

In iDevices with several text boxes, you can write directly in them. If you want the editor to 
be shown, you have to click on the "Editor" link.  

In this way the creation of activities is simpler, faster and more intuitive.  

Case study example: The Higgs Boson  

A few months ago, it was announced that it is considered by some to be "the greatest 
scientific discovery in history": the demonstration of the existence of the so-called Higgs 
Boson. But what exactly is the Boson? Why is this discovery so important?  

What are you made of? The particle of God . Presentation by J. David in Prezi, Public and reusable  

From this presentation, you propose that you carry out your own research on this topic 
from some activities.  

Search for information  

You ask you to look for two or three pages of Internet in which you can find information 
about the Higgs Boson: who was its discoverer, what is the theory that it presented and 
where and how that theory has finally been demonstrated.  

Oral presentation  

From the information obtained in the syources you have consulted before, you have to 
prepare an oral presentation in which you explain the essential aspects about the topic you 
are working on. You can also present the syources of information you have used.  

Practice eXe: Insert multimedia objects  

Perform the following procedures:  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Create an iDevice "Case study" in the "Insert multimedia objects" node. Modify the 
title.  

3. Search with your browser for a slidehare or prezi presentation and copy its "Embed" 
code.  

4. In the field "History" he writes an introduction text of the activity.  
5. By using the "Paste HTML fragment (embedded code)" button, paste the copied 

code. Press the "Insert" button  
6. In the field "Activity" propose a task related to the content that you have inserted. In 

the field "Feedback" includes some information or resource that is necessary to carry 
it out.  

7. Add another activity and complete it like the previous one: in the field "Activity" the 
work proposal and in the field "Feedback" the complementary information.  

https://translate.googleusercontent.com/translate_c?depth=1&hl=en&prev=search&rurl=translate.google.co.uk&sl=es&sp=nmt4&u=http://prezi.com/f6l-vakodoxx/boson-de-higgs/&xid=17259,15700002,15700022,15700124,15700149,15700168,15700173,15700186,15700201&usg=ALkJrhhs63hC5Mo_mmRIQxKvoMlVvAsv5g


8. When finished, click on the button to see the result.  
9. Save the changes. ( File> Save )  

iDevices of interactive activities  

To present questionnaires of different types of questions (with feedback and results) you 
will have these iDevices:  

 True-false question : proposes one (or several) questions that must be answered 
with "True" or "False".  

 Multi choice question : proposes one (or several) multiple choice questions to the 
student. Each of the questions can only have a correct answer.  

 Multi select question : proposes one (or several) test questions to the student. Each 
of the questions may have more than one correct answer.  

 SCORM Questionnaire : proposes one (or several) test questions to the student. It is 
similar in terms of operation to the iDevice "Multiple choice question" but allows 
communication with an LMS (Moodle), obtaining activity tracking data that indicate 
whether the exam has been approved or not.  

 Fill gaps : it offers the student a text with blank spaces that must be completed. 
Includes the possibility of feedback.  

 Expanding activity : it proposes to the student a text with a list of possible chains of 
words that must be selected.  

  



True / false question 

When selecting "True false question" from the list of iDevices this will be shown in your 
eXeLearning:  

 

At the top, you can modify the title of the iDevice.  

In the " Instructions " field write the text with the instructions to follow to ask the question 
True / False.  

In the " Question " field  write the text of the question. The statement should be clear. You 
will avoid negative premises since they tend to be ambiguous.  

Determine if the statement you have written is True or False, by checking the corresponding 
box  



In the " Feedback " field write the feedback that you want learners to see after doing the 
activity. If you leave this field empty, the default feedback will be offered.  

In the " Suggestion " field you can provide some clue that helps the student to correctly 
ansyour the question. You can leave the field blank.  

You can add new questions in the iDevice by clicking the " Add another question " button  

Remember:  

 When raising a case you can ask questions that generate doubts.  
 You can put questions next to a video to relate it to the objectives of the subject.  

The explanation associated with the answer is more important .  

True False question examples : eXeLearning iDevices  

Indicate if the following statements are true or false.  

Question 1  

eXe Learning is an open source tool  

True False  

Question 2  

A single file is used to install eXe in any operating system.  

True False  

Question 3  

The eXeLearning work environment has fyour distinct zones.  

True False  

Question 4  

The "Tools" option is part of the eXe Learning main menu.  

True False  

  



Practice eXeLearning: True or false?  

Try the following procedures:  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Create a new node called "Questions"  
3. Create an iDevice "True Question - False" in the "Questions" node. Modify the title.  
4. Search your browser for a video of your liking and insert it in the "Introduction" field. 

This time use the "Share" code and the "Paste HTML code (embedded code)" button.  
5. In the "Question" field, write a true statement about the subject that your video is 

about. Fill in the feedback and the suggestions field.  
6. Add another question in which you write a false statement. Fill in the same way the 

feedback and the suggestion. Remember that in these fields you can insert all kinds 
of resources.  

7. When finished, click on the button to see the result.  
8. Save the changes. ( File> Save )  

If you have any questions you can check the following video:  

  



Multi choice question  

Use this iDevice to propose one (or several) test questions to the learner. Each of the 
questions has one correct answer. It allows us to introduce several types of feedback that 
will be seen by the learner when the activities are completed or as hints to perform them. 
This type of activities let the learner check for themseves the assimilation of material 
worked on.   

When selecting "Multiple choice question" from the list of iDevices this will be shown in 
your eXeLearning:  

 

At the top, you can modify the title of the iDevice.  

In the " Question " field write the text of the question. The statement should be clear. You 
will avoid negative premises since they tend to be ambiguous.  

In the " Suggestion " field provide some clue that helps the student to correctly ansyour the 
question. You can leave the field blank.  

In the " Option " field write the text with the available response options. Mark in the button 
to the right of the field the option that is correct . You can add options by clicking the "Add 
another option" button. It will always be advisable to offer a range of between 3 and 4 
response options.  



In the " Feedback " field you will write the feedback that you want readers to see after 
doing the activity. If you leave the field empty, the default feedback will be offered.  

You can add new questions in the iDevice by clicking the "Add another question" button  

Multiple choice question example:  
Geography  

Top of Form 

Question  

The reunification of the two Germanies took place in ...  

Map of the division in West Germany and East Germany , and West Berlin in yellow.  

Answers  

Option 1  

1989  

Option 2  

1990  

Option 3  

1961  

https://translate.googleusercontent.com/translate_c?depth=1&hl=en&prev=search&rurl=translate.google.co.uk&sl=es&sp=nmt4&u=http://es.wikipedia.org/wiki/Alemania_Occidental&xid=17259,15700002,15700022,15700124,15700149,15700168,15700173,15700186,15700201&usg=ALkJrhj_wnThCKcOUH6vEWuwOTJGObJI9Q
https://translate.googleusercontent.com/translate_c?depth=1&hl=en&prev=search&rurl=translate.google.co.uk&sl=es&sp=nmt4&u=http://es.wikipedia.org/wiki/Alemania_Oriental&xid=17259,15700002,15700022,15700124,15700149,15700168,15700173,15700186,15700201&usg=ALkJrhh-tqdWBMmQTYNGptNn-943-5uJpA
https://translate.googleusercontent.com/translate_c?depth=1&hl=en&prev=search&rurl=translate.google.co.uk&sl=es&sp=nmt4&u=http://es.wikipedia.org/wiki/Alemania_Oriental&xid=17259,15700002,15700022,15700124,15700149,15700168,15700173,15700186,15700201&usg=ALkJrhh-tqdWBMmQTYNGptNn-943-5uJpA
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Feedback  

Practice eXeLearning: create a multiple choice question  

Try the following procedures:  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Create an iDevice "Multiple choice question" in the "Questions" node. Modify the 
title.  

3. In the field "Question" link a pdf file.  
4. Create three questions in the same iDevice, each with three possible response 

options.  

5. Once finished, click on the button to see the result.  
6. Save the changes. ( File> Save )  

Multi-select question  

Use this iDevice to propose one (or several) test questions to the student. Each of the 
questions may have more than one correct answer. It allows us to introduce a feedback that 
will be visualized by the student once the activity is completed. This type of activity will 
facilitate that the student can check for himself the assimilation of the contents worked on.  

When selecting "Multiple selection question" from the list of iDevices this will be shown in 
your eXeLearning:  

 



At the top, you can modify the title of the iDevice.  

In the " Question " field write the text of the question. The statement should be clear. Avoid 
negative premises since they tend to be ambiguous.  

In the " Option " field write the text with the available response options. In the box to the 
right of the field mark as many correct answers as necessary . You can add new options by 
clicking the "Add another option" button. It will always be advisable to add a range of 
between three and four response options.  

In the " Feedback " field write the feedback that you want learners to see after doing the 
activity. If you leave the field empty, the default feedback will be offered.  

You can add new questions in the iDevice by clicking the "Add another question" button  

Example of a multiple-choice question: Lorca  

Question  

Point out the true facts:  

Answers  

Option 1  

Lorca was born in Fuente Vaqueros, Granada  

Option 2  

He died in Madrid  

Option 3  

He died executed after the military uprising of the Spanish Civil War  

Practice eXe: create a multiple-choice question  

Try this:  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Create an iDevice "Multiple Selection Question" in the "Questions" node. Modify the 
title.  

3. Create three questions in the same iDevice, each with three possible response 
options. Select more than one option as correct in any of the questions.  

4. Once finished, click on the button to see the result.  
5. Save the changes. ( File> Save )  
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Cloze Activity 

In the Spanish language version this called “Fill the Gaps”. In the current English version this 
iDevice is called “Cloze Activity”. Use this iDevice to show the learner a text with blank 
spaces that must be completed. The activity includes the possibility of feedback.  

There are several correction options:  

 Flexibility in the answer : it admits as good the answers that only differ in one letter.  
 Admit error of the first capital letter : considers the word correct although the first 

letter (uppercase / lowercase) is not correct.  
 Immediate correction : corrects when completing the word without waiting for the 

user to request it.  

When selecting "Cloze Activity" from the list of iDevices this will be shown in eXeLearning:  

 

At the top you can modify the title of the iDevice.  

In the section " Instructions " write the text with the instructions to carry out the activity.  

In the section " Text with gaps to fill " you will write the text on which the activity will be 
created, selecting the word or words that you want to make disappear by clicking on the 
"Hide / show word" button.  



You will have the possibility to mark different correction options .  

Finally, in the section " Feedback ", you include those information and indications that can 
help or complement your student to perform the proposed activity.  

Did you know?  

You can create a gap in which several words are candidates for the correct word.  

For this you will have to write them between vertical lines: | house | apartment | chalet | 
and selecting the chain, press the show / hide button.  

Practice eXe: create an activity to fill gaps  

Try the following procedures:  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Create an iDevice "Fill gaps" in the "Questions" node. Modify the title.  
3. Create a text in which you at least hide two words or strings.  

4. Once finished, click on the button to see the result.  
5. Save the changes. ( File> Save )  

Drop down activity  

Use this iDevice to show a learner some text with a list of possible chains of words that 
should be selected. You can add new words (separated by "|" in the corresponding box) to 
increase the number of possible answers. You can also include general feedback and 
qualification.  

Selecting "Expanding activity" from the list of iDevices this will be shown in your 
eXeLearning:  



 

At the top, you can modify the title of the iDevice.  

In the section " Instructions " write the text with the instructions to carry out the activity.  

In the " Text " section write the text on which the activity will be created, selecting the word 
or words that you want to make disappear by clicking on the "Hide / show word" button.  

You can include " Other words ". For this write words separated by | ( Alt Gr + 1 ).  

Finally, in the section " Feedback " include information and hints that may help your 
learners  perform the proposed activity.  

Practice eXeLearning: create a drop-down activity  

Try the following procedures:  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Create an iDevice "Expanding activity" in the "Questions" node. Modify the title.  
3. Create a text where you hide at least two words or strings.  
4. Add two more words. Remember to separate them using | (Alt Gr 1)  

5. Once finished, click on the button to see the result.  
6. Save the changes. (File> Save)  



Scorm Questionnaire  

Use this iDevice to pose one (or several) test questions to the learner. It is similar in terms of 
operation to the iDevice "Multiple choice question" but allows communication with an LMS 
(Moodle) obtaining activity tracking data that indicate whether or not the exam has been 
approved.  

When selecting the iDevice "Scorm Questionnaire" from the list of iDevices this will be 
shown in your eXeLearning:  

 

At the top, you can modify the title of the iDevice.  

In the " Question " field write the text of the question. The statement should be clear. You 
will avoid negative premises since they tend to be ambiguous.  

In the " Options " field will write the text with the available response options. Mark in the 
button that is to the right of the field the correct option . You can add new options by 
clicking the "Add another option" button. It is advisable to add a range of between 3 and 4 
response options.  

You can add new questions in the iDevice by clicking the "Add another question" button and 
select the pass coefficient.  

In the end the system provides the percentage of hits: "Your score is 100%"  



Math exercises  

Question  

57-9 =  

Answers  

Option 1  

63  

Option 2  

48  

Question  

96 X 6  

Answers  

Option 1  

576  

Option 2  

456  

Practice eXe: create a scorm activity  

Try this:  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Create an iDevice "Scorm Questionnaire" in the "Questions" node. Modify the title.  
3. Create two questions with three possible options in each of them.  

4. When finished, click on the button to see the result.  
5. Save the changes. ( File> Save )  
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iDevices of non-textual information  

To display external resources that are incorporated into eXeLearning as content (textual or 
web) you have these iDevices:  

 Wikipedia article: includes all the information of a Wikipedia article, including 
images and their links.  

 RSS: makes a copy of thesourceof a website or blog.  

 Website : shows an external page within the content of eXeLearning.  

 Gallery of images: it shows an album of images, initially in miniature format.  

 Magnifying glass : shows an image and by means of a magnifying glass effect, 
magnifies it.  

 Java Applet: allows inserting different Java applets in the pages of a JClic, Geogebra, 
Descartes, Scratch project ...  

 Attached files : it allows you to attach the files with their corresponding links as a 
non-sorted list.  

Wikipedia article  

Use this iDevice to add all the information of a Wikipedia article, including images and their 
links. Bear in mind that when the content is loaded, a copy is made that is no longer 
updated. This has three consequences:  

 The content of the added article is not updated when it is updated in Wikipedia.  
 You can modify the content of the article in your material and show the modified 

version to your learners.  
 It  allows use of  the resource without an Internet connection.  

When selecting the iDevice "wikipedia article" from the iDevices list, the following will be 
shown in your eXeLearning:  



 

At the top, you can modify the title of the iDevice.  

In the "Site" drop-down you can choose the source which you want to search the content.  

In the following form write the word to search for and click on the "Load" button.  

You will be shown the content of the article in the last field, which can be edited.  

eXeLearning  practice: include a Wikipedia content  

Try the following procedures:  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Create a new node called "Information"  
3. Create an iDevice "Wikipedia article" in the "Information" node. Modify the title.  
4. Choose the language in which you are going to search for the content.  
5. Upload content from the Wikipedia of your interest or related to the topic you are 

working on.  

6. Once finished, click on the button to see the result.  
7. Save the changes. (File> Save)  

If you have any questions you can check the following video:   



RSS  

RSS is a simple data format used to push content to subscribers of a website. However, this 
iDevice does not respect the philosophy of syndication, since it makes a copy of the headline 
source and is frozen on the day the block is created. As with the iDevice "Wikipedia article", 
this has three consequences:  

 The content of the resource is not updated when the website it is syndicated to is 
updated.  

 You can modify the content of the article in your material to show it modified to 
your students.  

 Allows the use of the resource without an Internet connection.  

Selecting the iDevice "RSS" from the list of iDevices this will be shown in your eXeLearning:  

 

In the RSS URL text field, paste the RSS address. Remember to click on the Load button .  

On the loaded content you can make modifications. Observe the differences between Not 
highlighting and Moderate highlighting .  

 



Example of iDevice RSS: News from RIATE  

Retransmisión Moodle Moot'09 Madrid  

MOODLE MOOT MADRID  

COLLABORATE WITH RIATE. SEND YOUR PROPOSAL WITH THE NAME OF THE BULLETIN.  

Luis F Iglesias, the path of a teacher  

Argentina in the Educational Mercosur  

I INTERNATIONAL CONGRESS MINORS IN ICT  

CONGRESS SOFTWARE, EDUCATION AND FREE KNOWLEDGE  

Available in RIATE the Practical Guide on Free Software of UNESCO  

Practice activity  

Try the following procedures:  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Create an iDevice "RSS article" in the "Information" node. Modify the title.  
3. Search three syources of RSS content and add them to the iDevice.  
4. Next to the link to each rss, it includes a small description of the content.  

5. Once finished, click on the button to see the result.  
6. Save the changes. (File> Save)  

If you have any questions you can check the following video:  

External website  

Use this iDevice to include a web page within your resource, inside a framework. When an 
external website is displayed, what the iDevice does is connect to the Internet, get the web 
page and show it inside. A copy of the web page is not saved, so it will only work if you are 
connected to the Internet.  

Selecting the iDevice "External Website" from the list of iDevices you will be shown this in 
your eXeLearning:  
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In the URL text field, paste the address you want to embed.  

eXeLearning practice: incorporate an external website  

Try the following procedures:  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Create an iDevice "External website" in the "Information" node.  
3. Find a web page whose content you are interested in incorporating and include your 

url in the iDevice.  
4. Defines the size of the frame as "medium".  

5. Once finished, click on the button to see the result.  
6. Save the changes. (File> Save)  

If you have any questions you can check the following video:  

Image gallery  

eXelearning has updated how images are displayed. Clicking on one of them, it will be 
enlarged, showing the name of it and some miniatures of the rest of the gallery.  

Use this iDevice to show an album of images, initially in miniature format. Clicking on any of 
the images in the gallery will open an enlarged sample and the possibility of navigating 
between the different images in the gallery.  

When selecting the iDevice "Gallery of images" of the list of iDevices this will be shown in 
your eXeLearning:  



 

Add images from the Add images button.  

Once the first one is added, you can continue adding, deleting and moving from the buttons 
below each of them. Remember to write a descriptive text for each one.  

Example of an image gallery: Web 2.0  

 

  

  

Practice eXeLearning: create a gallery of images  

Try the following procedures:  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Search for images with a Creative Commons licenseand download them to a folder 
on your computer.  

3. Create an iDevice "Gallery of images" in the node "Information". Change your title  
4. Add the fyour images you have previously downloaded. For each of them write a 

small descriptive text.  

5. Once finished, click on the button to see the result.  
6. Save the changes. (File> Save)  

http://exelearning.net/html_manual/exe20/web2.png
http://exelearning.net/html_manual/exe20/web2b.jpg


Image Magnifier  

Use this iDevice to magnify an image. You can use this iDevice to focus the learner's 
attention and encourage them to explore maps, maps, photographs ...  

When selecting the iDevice "Image Magnifier" from the list of iDevices this will be shown in 
your eXeLearning:  

 

 

Practice eXeLearning: incorporate an image with an Image Magnifier  

Try the following procedures:  

1. Open the file myfile2.elp that you created in the previous activity (You can double 
click on it).  

2. Look for an image with a Creative Commons license and download it in a folder on 
your computer.  

3. Create an iDevice "Image Magnifier" in the "Information" node. Change your title  
4. Add the image you have previously downloaded.  
5. Align the image to the right, define the initial size as 100% and the final size as 200%. 

Define the size of the magnifying glass as medium or small.  

6. Once finished, click on the button to see the result.  
7. Save the changes. (File> Save)  



Java applet  

Use this iDevice to include resources made with other applications (Jclic, Descartes, Scratch, 
Geogebra, ...) Unlike the rest of the iDevices, whose use is simple, the use of this has a 
greater complexity, although in the latest version of eXeLearning this has been simplified a 
lot. Bear in mind that Java applets are a legacy technology and should be thoroughly tested 
in all potential use cases.  

As Java Applets are a legacy technology their use is not covered in detail, if you want to use 
them look at http://exelearning.net/html_manual/exe20/index.html and run the relevant section 
through Google Translate, knowing the context this is easy enough to follow. 

Attached files  

Use this iDevice to attach files to the package (which will be included when exporting it).  

Selecting the iDevice "Attached files" from the list of iDevices this will be shown in your 
eXeLearning:  

 

  

http://exelearning.net/html_manual/exe20/index.html


It comes with two viewing options:  

 Show the description and the link (YES): the uploaded files will be displayed in an 
unordered list with links.  

 Show the description and the link (NO): the files do not appear in the exported ones 
but they are included in both the elp and the exported ones. This form complements 
the file introduction mechanism through the Java iDevice Applet. Only for an 
advanced user.  

Remember to use the Load button every time you want to add a new file.  

Example of attached files: two pdf  

You show the files that you must download to complete your self-evaluation:  

• Evaluation diary (New window)  

• Experience in the classroom (New window) 

Embed external resources  

eXeLearning 2.1  can embed live external resources from the Internet but remember that 
these will not display if there is no Internet connection. If the web resource has an embed 
option cut and paste their embed HTML code into your eXeLearning package. 

Merge elps  

The option "Merge elps" lets you extract or insert eXeLearning packages. In this way, you 
can combine parts of different projects to obtain a new one. The existing options are:  

 Insert package : insert an .elp package from the position in the content structure 
that you have selected.  

 Extract package : create a new .elp package with the selected page or node. Includes 
all the subpages that are in the lower branches of the content tree.  

  



Practice eXeLearning: download and organize content  

Try the following procedures:  

1. Create a folder on your PC called "Downloaded resources".  
2. Access three of the resource pages that appear in the previous section.  
3. Download the elp corresponding to three resources of your subject in the 

"Downloads" folder.  
4. Open each resource with eXe and modify its style (so that all three have the same) 

and properties.  
5. Save each one of the elps.  
6. Publish them to see the format of each of them.  

Insert package  

Use the option Merge Elps> Insert package when you want to include earlier work that you 
have done or elps that you have downloaded from the Internet.  

Take into account the licenses of the new package.  

1.- In the content tree select the node from which you want to insert the new content.  

2.- Clicking on the right mouse button shows the option "Insert package". It is possible 
to access this option from the menu File> Merge Elps.  

3.- Selecting this option opens a navigation window where you will select the package 
.elp to insert.  

4.- Once selected, the content of the new package will be integrated in a lower level 
than the node from which you inserted it.  



 

Note the metadata and information in the properties tab of the package you are working on 
are maintained and are not changed by inserting new elps. If the inserted package has 
metadata, this will be deleted.  

Practice eXeLearning: insert package  

Try the following procedures:  

1. Open your file any of the ones you have downloaded.  
2. Insert in it another of the files that you downloaded or the didactic unit with which 

you have worked.  
3. Modify the properties of the .elp.  
4. Save the resulting .elp with a different name.  
5. Make the export to see the result.  

  



Extract package  

Use the option to Merge Elps> Extract package when you want to unbundle your work in 
smaller files.  

1.- In the content tree you will select the node from which you want to extract the content.  

2.- Clicking on the right mouse button will show us the option "Extract package". It is 
possible to access this option from the menu File> Merge Elps.  

3.- Selecting the option will open a navigation window where you can give a new name to 
the package that you are going to create.  

Note the elp obtained from the extraction retains in the properties tab the name of the 
original author. As a title, it will show by default the one of the parent node, but the rest of 
the fields will have to be filled in as it is a new content.  

Practice eXe: extract package  

Try the following procedures:  

1. Open a .elp file  
2. Extract at least two different nodes. Save them in your "Downloaded resources" 

folder with the names ext01, ext02  
3. Open each one of them and check that the contents look correct.  
4. Try to merge these extracted contents with any of the .elp files that you downloaded 

in the initial unit.  
5. Save the resulting new .elp with the names fus01, fus02.  

Publishing content  

With eXeLearning, it is easy to create content to be published in different formats.  

Website: self-contained folder and unique html  

eXeLearning allows us to export HTML in different ways: as a self-contained folder, as a 
compressed file or as a single page (the index of contents will not be shown).  

Advanced users 

The HTML export options work but they are one of the weaker areas of eXeLearning 

 When the HTML is exported all the files are placed in a single folder, placing all of 
the pictures and images in a separate sub folder makes it much easier to use. 

 eXeLearning exports a complete set of icons whether they are used in the content or 
not.  



These weaknesses can be fixed by some editing of the HTML export. 

Export from eXeLearning to a self contained folder then: 

1. Modify the html export generated by eXeLearning by placing all of the images in a 
new sub folder called image  

2. In a text editor carry out a find and replace on the HTML code  in all of the HTML files 
replacing src=" with src="image/ this will change the path to image source files but 
also changes the path to java script source files so. 

3. Carry out a find and replace on the html replacing <script type="text/javascript" 
src="image/ with <script type="text/javascript" src=" 

4. Delete unused icon files from the image folder 

If you want to publish it on the web?  

To host HTML content, it is usual to hire a hosting service and upload files via FTP or other 
similar technology.  

Educational standards  

SCORM 1.2, IMS, SCORM 2004, Common Cartridge Package, are the export standards 
supported in eXeLearning.  They are used in learning management systems.  

Publish in a Learning Management System as SCORM 1.2  

SCORM (Sharable Content Object Reference Model) is a specification to create structured 
pedagogical objects. The original web content management systems used proprietary 
formats for the content they distributed. So the exchange of such content was not possible. 
With SCORM it is possible to create content that can be imported into different learning 
management systems (such as Moodle), provided that they support the SCORM standard. 
The main requirements the SCORM model tries to satisfy are:  

 Accessibility : ability to access teaching components from a distant site through web 
technologies, as well as distribute them to other sites.  

 Adaptability : ability to customize training according to the needs of people and 
organizations. Durability: ability to resist the evolution of technology without 
needing  a reconfiguration or a rewriting of the code.  

 Interoperability : ability to be used in another location, with another set of tools or 
on another platform of teaching components developed within a site, with a certain 
set of tools or on a certain platform. There are numerous levels of interoperability.  

 Reusability : flexibility that allows integrating teaching components within multiple 
contexts and applications.  



The result of export in SCORM 1.2, a compressed package (.zip) is made that can be 
imported transparently to the user from all LMS platforms (for example Moodle, Sakai, ...) 
that support this specification.  

Publish in a Learning Management System as IMS (IMS CP)  

IMS is a skeleton of specifications that helps define various technical standards, including e-
learning materials. The IMS Content Packaging specification makes it possible to store the 
contents in a standard format, which can be reused in different systems without having to 
convert these contents to other formats.  

The specifications of this resource also allow the complete definition of the same with the 
use of metadata (IMS Metadata); defining authorships, taxonomies ...  

The specific objective of this application is the organization of the different elements of a 
package. Therefore, unlike the SCORM packages, it does not have a standardized language 
to exchange information with the platform during the use of the resource and therefore 
does not allow monitoring of the work of the students.  

The IMS CP type resource in Moodle allows use of this type of content packages, loading 
them and including them in courses. Publish in Moodle as HTML  

You can incorporate your exported HTML content into Moodle or another LMS.  

EPUB 3  

EPUB is an open standard for e-books, consider carefully before you choose it as a way of 
distributing your elearning resource.  There are limitations and eXeLearning is not designed 
with them in mind. Look at the article: " The new version of eXeLearning allows you to 
export to ePub3 "  first. 

https://translate.googleusercontent.com/translate_c?depth=1&hl=en&prev=search&rurl=translate.google.co.uk&sl=es&sp=nmt4&u=http://blog.educalab.es/intef/2014/11/04/la-nueva-version-de-exelearning-permite-exportar-a-epub3/&xid=17259,15700002,15700022,15700124,15700149,15700168,15700173,15700186,15700201&usg=ALkJrhjGgMMfvSm9iu2FzpwaY0p7mevj5Q
https://translate.googleusercontent.com/translate_c?depth=1&hl=en&prev=search&rurl=translate.google.co.uk&sl=es&sp=nmt4&u=http://blog.educalab.es/intef/2014/11/04/la-nueva-version-de-exelearning-permite-exportar-a-epub3/&xid=17259,15700002,15700022,15700124,15700149,15700168,15700173,15700186,15700201&usg=ALkJrhjGgMMfvSm9iu2FzpwaY0p7mevj5Q

